注册 登录
主题 : 打开系统设置的照片权限页面时遇到“OSStatus”错误 -10814。
级别: 精灵王

状态: 连续签到 - [75天]
UID: 481670
精华: 0
发帖: 1017
可可豆: 1557 CB
威望: 1418 点
在线时间: 691(时)
注册时间: 2015-06-16
最后登录: 2017-09-25
0 楼:  发表于: 2016-12-19 10:28    发自: Web Page
来源于 调试问题 分类

打开系统设置的照片权限页面时遇到“OSStatus”错误 -10814。   

  要检测用户是否打开访问照片的权限,先在URL types设置了,设置如图,并设置了跳转代码:
[[UIApplication sharedApplication] openURL:[NSURL URLWithString:@"prefs:root=Privacy&path=PHOTOS"]];

然而他没跳转,于是写了下面的代码检查的:
BOOL isCan = [[UIApplication sharedApplication]canOpenURL:[NSURL URLWithString:@"prefs:root=Privacy&path=PHOTOS"]];
,控制台输出了下面的提示:
2016-12-19 10:11:49.185158 94Bank[1250:507239] -canOpenURL: failed for URL: "prefs:root=Privacy&path=PHOTOS" - error: "未能完成操作。(“OSStatus”错误 -10814。)"
那么。。我该怎么办。。。我的错误在哪里?
程序猿,永不为奴!🐒🐒🐒🐒🐒
级别: 精灵王

状态: 连续签到 - [75天]
UID: 481670
精华: 0
发帖: 1017
可可豆: 1557 CB
威望: 1418 点
在线时间: 691(时)
注册时间: 2015-06-16
最后登录: 2017-09-25
1 楼:  发表于: 2016-12-19 10:33    发自: Web Page
看在我头像的份上,有人来解答一下吗
程序猿,永不为奴!🐒🐒🐒🐒🐒
级别: 精灵王

状态: 连续签到 - [75天]
UID: 481670
精华: 0
发帖: 1017
可可豆: 1557 CB
威望: 1418 点
在线时间: 691(时)
注册时间: 2015-06-16
最后登录: 2017-09-25
2 楼:  发表于: 2016-12-19 10:50    发自: Web Page
HELP
程序猿,永不为奴!🐒🐒🐒🐒🐒
级别: 精灵王

状态: 连续签到 - [75天]
UID: 481670
精华: 0
发帖: 1017
可可豆: 1557 CB
威望: 1418 点
在线时间: 691(时)
注册时间: 2015-06-16
最后登录: 2017-09-25
3 楼:  发表于: 2016-12-19 11:03    发自: Web Page

程序猿,永不为奴!🐒🐒🐒🐒🐒
级别: 新手上路

状态: 连续签到 - [28天]
UID: 544261
精华: 0
发帖: 53
可可豆: 205 CB
威望: 144 点
在线时间: 104(时)
注册时间: 2016-02-23
最后登录: 2017-08-31
4 楼:  发表于: 2016-12-19 11:22    发自: Web Page
看在你头像的份上,我来顶一下!
顶!
顶!
顶!
级别: 精灵王

状态: 连续签到 - [75天]
UID: 481670
精华: 0
发帖: 1017
可可豆: 1557 CB
威望: 1418 点
在线时间: 691(时)
注册时间: 2015-06-16
最后登录: 2017-09-25
5 楼:  发表于: 2016-12-19 13:22    发自: Web Page
回 4楼(XiangHongJiang) 的帖子
  
程序猿,永不为奴!🐒🐒🐒🐒🐒
级别: 精灵王
状态: 连续签到 - [22天]
UID: 431391
精华: 0
发帖: 818
可可豆: 1234 CB
威望: 1180 点
在线时间: 1458(时)
注册时间: 2015-01-20
最后登录: 2017-09-25
6 楼:  发表于: 2016-12-19 13:40    发自: Web Page
http://blog.csdn.net/li1990101010/article/details/50864126

  不知道能否帮上忙
级别: 骑士
状态: 连续签到 - [85天]
UID: 530891
精华: 0
发帖: 214
可可豆: 717 CB
威望: 508 点
在线时间: 675(时)
注册时间: 2015-12-12
最后登录: 2017-09-20
7 楼:  发表于: 2016-12-20 10:51    发自: Web Page
遇到了同样的问题  求大神解答
级别: 侠客
状态: 连续签到 - [127天]
UID: 513762
精华: 0
发帖: 65
可可豆: 882 CB
威望: 601 点
在线时间: 209(时)
注册时间: 2015-10-14
最后登录: 2017-09-04
8 楼:  发表于: 2017-01-20 11:00    发自: Web Page
似乎iOS 10之后就不能从APP里打开系统设置页面了。
级别: 新手上路
UID: 506580
精华: 0
发帖: 28
可可豆: 28 CB
威望: 28 点
在线时间: 77(时)
注册时间: 2015-09-16
最后登录: 2017-08-04
9 楼:  发表于: 2017-07-17 19:24    发自: Web Page
NSURL * url = [NSURL URLWithString:@"App-Prefs:root="];  这个可以跳转到设置页面
描述
快速回复

关注本帖(如果有新回复会站内信通知您)

发帖、回帖都会得到可观的积分奖励。查看论坛积分规则

按"Ctrl+Enter"直接提交
    顶部