注册 登录
主题 : 来人救救命啊
级别: 侠客

状态: 连续签到 - [78天]
UID: 620658
精华: 0
发帖: 123
可可豆: 625 CB
威望: 512 点
在线时间: 223(时)
注册时间: 2017-08-07
最后登录: 2019-08-24
0 楼:  发表于: 2019-08-12 11:44    发自: Web Page
来源于 一般提问 分类

来人救救命啊   

老项目!Xcode10上面各种问题!到这里的时候卡住了,好几天了。大佬们帮帮忙!
这到底是啥问题啊
图片:1.jpg
级别: 精灵王

状态: 连续签到 - [86天]
UID: 510329
精华: 0
发帖: 789
可可豆: 1238 CB
威望: 1057 点
在线时间: 1146(时)
注册时间: 2015-09-30
最后登录: 2019-08-23
1 楼:  发表于: 2019-08-12 13:40    发自: Web Page
这个很简单把,百度一下就知道,库引用的问题,https://blog.51cto.com/6095891/2337162,跟这个是一样的,在工程里引用libc.tbd库就好了
级别: 侠客

状态: 连续签到 - [78天]
UID: 620658
精华: 0
发帖: 123
可可豆: 625 CB
威望: 512 点
在线时间: 223(时)
注册时间: 2017-08-07
最后登录: 2019-08-24
2 楼:  发表于: 2019-08-12 13:46    发自: Web Page
回 1楼(564282030) 的帖子
在Xcode10里面加了libc.tdb没有用始终报这个错误,然后索性下了Xcode9还是报这个错
级别: 精灵王

状态: 连续签到 - [86天]
UID: 510329
精华: 0
发帖: 789
可可豆: 1238 CB
威望: 1057 点
在线时间: 1146(时)
注册时间: 2015-09-30
最后登录: 2019-08-23
3 楼:  发表于: 2019-08-12 14:02    发自: Web Page
你项目用了什么的第三方的静态库吗,需要更新一下,也许是这些第三方库打包的时候缺这个
级别: 侠客

状态: 连续签到 - [78天]
UID: 620658
精华: 0
发帖: 123
可可豆: 625 CB
威望: 512 点
在线时间: 223(时)
注册时间: 2017-08-07
最后登录: 2019-08-24
4 楼:  发表于: 2019-08-12 14:40    发自: Web Page
回 3楼(564282030) 的帖子
只能把全部第三方重新导一次了
级别: 新手上路
状态: 连续签到 - [3天]
UID: 444696
精华: 0
发帖: 25
可可豆: 47 CB
威望: 48 点
在线时间: 301(时)
注册时间: 2015-03-04
最后登录: 2019-08-21
5 楼:  发表于: 2019-08-12 16:21    发自: Web Page
建议还是用CocoaPods
级别: 新手上路
UID: 682301
精华: 0
发帖: 2
可可豆: 2 CB
威望: 2 点
在线时间: 0(时)
注册时间: 2019-08-15
最后登录: 2019-08-20
6 楼:  发表于: 2019-08-15 09:00    发自: Web Page
你是不是可以尝试 , 把错误提示中的库都在左侧目录下面的项目索引中搜索一下 , 看看是不是出现了两个 , 如果没有 , 就去framework把库删除重新添加(可能库太老了 , 或者弃用了 , 或者路径换了 ).
级别: 侠客
状态: 连续签到 - [3天]
UID: 316237
精华: 0
发帖: 142
可可豆: 183 CB
威望: 168 点
在线时间: 631(时)
注册时间: 2014-05-18
最后登录: 2019-08-23
7 楼:  发表于: 2019-08-15 14:48    发自: Web Page
没导入,要么就是路径错误。
Hello Alan
级别: 新手上路
UID: 524903
精华: 0
发帖: 4
可可豆: 22 CB
威望: 22 点
在线时间: 80(时)
注册时间: 2015-11-20
最后登录: 2019-08-15
8 楼:  发表于: 2019-08-15 14:50    发自: Web Page
回 2楼(机智勇敢怪我咯丶) 的帖子
增加libstdc++6.0.9这个系列的依赖库进去
级别: 新手上路
状态: 连续签到 - [1天]
UID: 217293
精华: 0
发帖: 7
可可豆: 22 CB
威望: 19 点
在线时间: 39(时)
注册时间: 2013-04-07
最后登录: 2019-08-21
9 楼:  发表于: 2019-08-16 09:30    发自: Web Page
不知道为什么贴不了图片
注意看一下问题图片中间偏下位置stdlib开头的一行
看样子应该是缺少libstdc++6.0.9库,Xcode自从Xcode10移除了libstdc++6.0.9.tdb,具体解决方案就是找个老版本的Xcode的libstdc++6.0.9,或者从网上找一下这个库,然后添加到项目里

CocoaChina社区转载内容已尽可能注明出处,如未能核实来源或转发内容图片有权利瑕疵的,请及时联系社区进行修改或删除【联系方式QQ : 3442093904 邮箱:support@cocoachina.com】文章内容为作者独立观点,不代表CocoaChina社区立场。版权归原作者所有,如申请授权请联系作者,因文章侵权CocoaChina社区不承担任何法律及连带责任。

描述
快速回复

关注本帖(如果有新回复会站内信通知您)

发帖、回帖都会得到可观的积分奖励。查看论坛积分规则

按"Ctrl+Enter"直接提交
    顶部