注册 登录
主题 : Cocos Studio和Cocos2d-x版本对应关系
级别: 风云使者

状态: 连续签到 - [30天]
UID: 183396
精华: 4
发帖: 4881
可可豆: 5742 CB
威望: 5905 点
在线时间: 1806(时)
注册时间: 2012-12-04
最后登录: 2017-08-31
0 楼:  发表于: 2014-01-21 11:57    发自: Web Page

Cocos Studio和Cocos2d-x版本对应关系   

管理提醒: 本帖被 DDDigua 执行取消置顶操作(2015-03-11)
可以在cocos2d.cpp中查看2d-x的版本信息。


版本对应列表:
Studio2.x
CocosStudio版本对应Cocos2d-x版本JS版本  备注
v2.1.5
v2.1.2beta
v2.1 (事件:更名Cocos)
v3.4finalv3.3 rc0+Cocos新增JSON格式导出,Cocos2d-JS仅支持此格式
v2.1betav3.4beta0不支持已分离出reader,可以将reader拉取到其他版本cocos2d-x,以支持新版本的CocosStudio
v2.0.6v3.3final不支持
v2.0.5v3.3rc2不支持
v2.0.2v3.3rc2不支持
v2.0beta0v3.3rc0v3.1


Studio1.x
CocosStudio版本2d-x v3版本2d-x v2版本2d-JS版本
1.6.0.03.22.2.53.1
1.5.0.13.22.2.53.0 RC2
1.5.0.03.02.2.43.0 RC2
1.4.0.13.02.2.33.0 RC2
1.4.0.03.02.2.33.0 RC2
1.3.0.13.0rc12.2.33.0 Alpha
1.3.0.03.0rc02.2.3
1.2.0.13.0beta2.2.2
1.1.0.0
2.2.1
1.0.0.2
2.2.0
1.0.0.1


1.0.0.0






-----------------
PS:一般来说高版本2dx能加载低版本的Studio1.x数据,
高版本的Studio1.x数据不一定能够被低版本的2d-x加载
-----------------

以下的版本是Cocos Studio独立发布cocos2d-x包,该包是基于cocos2d-x包的扩展包。
如果您使用的1.0.0.0版本之前的Cocos Studio编辑器,建议您同步升级编辑器和引擎到最新的版本。

// 如果您因特殊原因无法下载最新的版本,那么您可以到http://www.cocoachina.com/bbs/read.php?tid=154886下载对应的版本 
//现在老版本已下架,下载链接打不开,特此注释


2.1.5b                                |                   0.4.0.0


2.1.5a                                |                   0.3.3.0


2.1.4h                                |                    0.3.2.0


2.1.4g                                |                    0.3.1.0


2.1.4f                                |                     0.3.0.0


2.1.4e                                |                    0.2.4.1


2.1.4d                                |                     0.2.4.0


2.1.4c                                |                     0.2.3.


2.1.4b                                |                    0.2.2


2.1.4b                                |                    0.2.1

2.1.4b                                |                    0.2.0

2.1.4a                                |                    0.1.7


----------------------------
再之前的版本是版本是单独发布的guilib扩展包
包括以下Cocos Studio版本:
/0.1.6/0.1.5/0.1.4/0.1.3/0.1.2/0.1.1




[ 此帖被DDDigua在2016-02-23 11:31重新编辑 ]

级别: 新手上路
UID: 305217
精华: 0
发帖: 6
可可豆: 15 CB
威望: 15 点
在线时间: 6(时)
注册时间: 2014-04-03
最后登录: 2014-04-08
1 楼:  发表于: 2014-04-03 17:00    发自: Web Page
回 楼主(hanrea) 的帖子
如果只有2.1.4后面没跟其他东西,怎么判断具体版本号?
级别: 新手上路
状态: 连续签到 - [4天]
UID: 307615
精华: 0
发帖: 5
可可豆: 21 CB
威望: 17 点
在线时间: 47(时)
注册时间: 2014-04-13
最后登录: 2017-09-14
2 楼:  发表于: 2014-06-29 17:10    发自: Web Page
Cocos Studio和Cocos2d-x版本必须是一一对应的吗
级别: 侠客
UID: 137143
精华: 0
发帖: 84
可可豆: 156 CB
威望: 156 点
在线时间: 237(时)
注册时间: 2012-04-17
最后登录: 2016-04-01
3 楼:  发表于: 2014-06-30 11:23    发自: Web Page
回 2楼(霹雳火) 的帖子
对的,因为cocos2d-x每个版本的解析库是不一样的,所以如果不对应版本使用的话就会出现解析层的崩溃问题。
级别: 新手上路
状态: 连续签到 - [1天]
UID: 318114
精华: 0
发帖: 4
可可豆: 16 CB
威望: 18 点
在线时间: 27(时)
注册时间: 2014-05-24
最后登录: 2014-10-07
4 楼:  发表于: 2014-07-04 23:14    发自: Web Page
为什么cocos2dx3.1 对应的版本是cocostudio1.4.0.0  ,而 cocos2dx2.4对应cocostudio1.5  这版本越高对应的还越低,真不解

图片:20140704231118.png
级别: 新手上路
UID: 262199
精华: 0
发帖: 19
可可豆: 64 CB
威望: 64 点
在线时间: 28(时)
注册时间: 2013-09-21
最后登录: 2014-09-01
5 楼:  发表于: 2014-07-09 14:45    发自: Web Page
js3.0 rc 用的是cocos2d-x 3.2alpha0?
级别: 圣骑士
状态: 连续签到 - [13天]
UID: 298324
精华: 6
发帖: 483
可可豆: 800 CB
威望: 798 点
在线时间: 282(时)
注册时间: 2014-03-08
最后登录: 2015-03-20
6 楼:  发表于: 2014-07-16 10:28    发自: Web Page
回 楼主(hanrea) 的帖子
我也有和四楼相同的疑惑,可以解释下吗?
欢迎访问cocos2d-x博客www.zaojiahua.com皂荚花。
级别: 侠客
状态: 连续签到 - [12天]
UID: 127188
精华: 0
发帖: 91
可可豆: 426 CB
威望: 384 点
在线时间: 232(时)
注册时间: 2012-03-02
最后登录: 2015-01-16
7 楼:  发表于: 2014-07-16 10:49    发自: Web Page
无法理解 3.2版的引擎  对应的cocostudio 居然是1.4  
为做伟大的游戏而奋斗不息
级别: 侠客
UID: 105121
精华: 0
发帖: 157
可可豆: 332 CB
威望: 312 点
在线时间: 344(时)
注册时间: 2011-11-15
最后登录: 2017-06-14
8 楼:  发表于: 2014-07-16 13:26    发自: Web Page
引用
引用第4楼iasxkj于2014-07-04 23:14发表的  :
为什么cocos2dx3.1 对应的版本是cocostudio1.4.0.0  ,而 cocos2dx2.4对应cocostudio1.5  这版本越高对应的还越低,真不解





2d-x的3.x在全力开发, 2.x进入维护期。


3.1发布发布时间更早, 很简单

级别: 风云使者

状态: 连续签到 - [30天]
UID: 183396
精华: 4
发帖: 4881
可可豆: 5742 CB
威望: 5905 点
在线时间: 1806(时)
注册时间: 2012-12-04
最后登录: 2017-08-31
9 楼:  发表于: 2014-07-16 16:26    发自: Web Page
回 4楼(iasxkj) 的帖子
2.x和3.x目前属于并行的两个版本,虽然2.x版本仅作维护性更新,但并不和3.x版本有冲突。
描述
快速回复

关注本帖(如果有新回复会站内信通知您)

发帖、回帖都会得到可观的积分奖励。查看论坛积分规则

按"Ctrl+Enter"直接提交
    顶部