首页 >iOS开发

使用CocoaPods管理第三方开源类库

2014-05-19 14:07 编辑: qiancheng 分类:iOS开发 来源:CocoaChina

转自Colinhou的博客

 

iOS开发中经常会用到许多第三方开源类库,比如AFNetworking、FMDB、JSONKit等等,使用CocoaPods这个工具就能很方便得对工程中用到的类库进行管理,包括自动下载配置以及更新。

 
首先需要下载安装CocoaPods,系统要求有ruby环境,至少OS X 10.9以后是自带ruby环境的(Python也自带了),使用“ruby -v”命令可以查
 
看当前ruby版本。
 
配置过程如下:
 
1.ruby环境
 
不放心的话可以先确认下ruby环境,据说由于GFW的影响,大都把Ruby镜像指向taobao的(其实上个月第一次用的时候没有设置,现在为了稳定性还是换吧),执行以下命令:
  1. gem sources --remove https://rubygems.org/ 
  2. gem sources -a http://ruby.taobao.org/ 
  3. gem sources -l  (用来检查使用替换镜像位置成功) 
 
2.下载CocoaPods
 
执行如下命令:
  1. sudo gem install cocoapods 
 
3.使用CocoaPods
 
安装完成后即可使用了,通过CocoaPods来下载使用第三方类库,首先要检查CocoaPods是否支持目标类库,虽然大多数都是支持的。
比如检查是否支持AFNetworking,执行命令“pod search AFNetworking”,即可看到相关信息。
 
下面举个例子如何在一个名为“DemoMap”的项目里使用CocoaPods管理第三方类库,进入项目所在目录,并建立Podfile(配置文件)
 
执行两条命令:
  1. cd /hou/DemoMap 
  2. vim Podfile 
按下“i”,进入编辑模式,在Podfile中输入以下信息(根据GitHub中提示信息获得):
  1. platform :ios, '7.0' 
  2. pod "AFNetworking""~> 2.0" 
 
按下ESC键,退出编辑模式,输入:wq,进行保存操作。
输入pod install开始自动下载并配置好,以后打开项目用.xcworkspace后缀的文件即可。
Pods文件夹中存放的就是下载好的第三方依赖库。
打开后可以发现,项目工程中已经自动引入了AFNetworking。
在工程里引用头文件后就可以直接使用了。如果类库有更新,可以按照第3步的办法对配置文件进行更新,然后执行“pod update”即可。
 
另外,在GitHub上下载了某个开源项目后,如果该项目使用了CocoaPods,可以直接cd到项目工程所在目录,执行“pod install”即可一次把所有用到的第三方依赖库下载配置好,比起一个个下载好再导入,方便太多了。
搜索CocoaChina微信公众号:CocoaChina
微信扫一扫
订阅每日移动开发及APP推广热点资讯
公众号:
CocoaChina
我要投稿   收藏文章
上一篇:自定义 Layer 属性的动画
下一篇:iOS 交互式动画
我来说两句
发表评论
您还没有登录!请登录注册
所有评论(0

综合评论

相关帖子

sina weixin mail 回到顶部